[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.2.0rc4 FAIL on MacOSX 10.4

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2005-05-15 13:56:00 CEST

On 5/15/05, David Chilton <David-Chilton@utc.edu> wrote:
> the command-line said "Running all tests in translate-
> test...FAILURE", there are a several Lines starting with XFAIL in the
> log also.

Yes, but those are eXpected FAILures. They won't show up as FAILUREs
in the summarized output.
 
> >> I'm sorry I miss read the instructions on the svn-brakage list
> >> instructions and thought it saif to copy to this list, many many
> >> apologies, it won't happen again
> >>
> >>
> >
> > Since there were no failed tests in that log, why did you think
> > there wer failures? Did 'make check' say something about failure?
> >
> > I build svn on OSX 10.4 everyday, and have never seen any test
> > failures, so it might be interesting to know if you've really seen
> > something different, and why.

Well, actually, if you look closely at the output of translate-tests
there is something weird going on: none of the tests have reported
either success or failure: which normally indicates segfaulting.

David, you might have been on to something. Could you run
translate-tests standalone (ie not from the test suite scripts) and
tell us what the output says?

bye,

Erik.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sun May 15 13:56:42 2005

This is an archived mail posted to the Subversion Dev mailing list.