[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Medium-term roadmap: 1.3, 1.4, 1.5.

From: Andrew Thompson <subversionuser_at_aktzero.com>
Date: 2005-04-25 19:01:50 CEST

Joseph Galbraith wrote:
> Ben Collins-Sussman wrote:
>> Apache is no more a "3rd party application" than any other depenency,
>> like neon for example.

Not Apache, Apache2. Apache is installed by default in almost every
"full" installation of linux.

> And at my company (a windows shop) the requirement to use
> apache to deny certain users read access to certain files in the
> repository (functionality we have with SourceSafe) is a
> hard sell (and rightfully so.)

Please point me to svnserve compatible hooks that enforce read access to
a repository?

<snip>
> Or even running svnserve directly (if it had SSL support.)

That would be very nice. I wonder if a tcp wrapper of some kind could
handle that.

> PS. I think the decision to use apache for security in 1.0 was a very
> reasonable decision... I just wouldn't want to see it become permenant.

I have absolutely no issue with apache2 mediating security if you want
to/can run apache2.

-- 
Andrew Thompson
http://aktzero.com/
Interested in a hosted SVN repository? Email me, let's talk...
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Apr 25 19:03:13 2005

This is an archived mail posted to the Subversion Dev mailing list.