[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Problems running the client--Symbols missing in libsvn_ra-1.0.dylib on Mac OS X

From: Robert <robertLinux_at_gmx.de>
Date: 2005-04-22 13:04:21 CEST

Hello.
I compiled svn 1.1.4 on Mac OS X.3.9 together with a fresh Apache
2.0.54. Apache server runs and is accessible through a browser but the
client refuses to work. I tried installation several times but now I am
out of ideas. Could someone be so kind to help me install svn again?

Thank you in advance,
Robert Welz

welz$ /usr/local/subversion_1_1_4/bin/svn --version
dyld: /usr/local/subversion_1_1_4/bin/svn Undefined symbols:
/usr/local/subversion_1_1_4/bin/svn undefined reference to
_XML_ErrorString expected to be defined in
/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
/usr/local/subversion_1_1_4/bin/svn undefined reference to
_XML_GetCurrentLineNumber expected to be defined in
/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
/usr/local/subversion_1_1_4/bin/svn undefined reference to
_XML_GetErrorCode expected to be defined in
/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
/usr/local/subversion_1_1_4/bin/svn undefined reference to _XML_Parse
expected to be defined in
/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
/usr/local/subversion_1_1_4/bin/svn undefined reference to
_XML_ParserCreate expected to be defined in
/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
/usr/local/subversion_1_1_4/bin/svn undefined reference to
_XML_ParserFree expected to be defined in
/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
/usr/local/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
/usr/local/subversion_1_1_4/bin/svn undefined reference to
_XML_SetElementHandler expected to be defined in
/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
/usr/local/subversion_1_1_4/bin/svn undefined reference to
_XML_SetUserData expected to be defined in
/usr/local/subversion_1_1_4/lib/libsvn_ra-1.0.dylib
Trace/BPT trap

The library libsvn_ra-1.0.dylib is in its place and is a link to
libsvn_ra-1.0.0.0.dylib and is 20.100 Bytes in size.

During make install I got a warning like this:

*** Warning: This system can not link to static lib archive
/Volumes/Dokumente/Dokumente/Downloads/subversion/neon/src/libneon.la.
*** I have the capability to make that library automatically link in
when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have.
gcc -r -keep_private_externs -nostdlib -o
.libs/libsvn_ra_dav-1.0.0.0.dylib-master.o commit.lo fetch.lo
file_revs.lo log.lo merge.lo options.lo props.lo session.lo util.lo &&
gcc -dynamiclib -flat_namespace -undefined suppress -o
.libs/libsvn_ra_dav-1.0.0.0.dylib
.libs/libsvn_ra_dav-1.0.0.0.dylib-master.o
-L/Volumes/Dokumente/Dokumente/Downloads/subversion/apr/.libs
-L/usr/lib
-L/Volumes/Dokumente/Dokumente/Downloads/subversion/apr-util/xml/expat/
lib/.libs
-L/Volumes/Dokumente/Dokumente/Downloads/subversion/apr-util/.libs
-L/Volumes/Dokumente/Dokumente/Downloads/subversion/subversion/
libsvn_subr/.libs
-L/Volumes/Dokumente/Dokumente/Downloads/subversion/apr-util/xml/expat/
lib /usr/local/subversion_1_1_4/lib/libsvn_delta-1.dylib
/usr/local/subversion_1_1_4/lib/libsvn_subr-1.dylib
/usr/local/subversion_1_1_4/lib/libaprutil-0.dylib
/usr/local/subversion_1_1_4/lib/libexpat /usr/lib/libiconv.dylib
/usr/local/subversion_1_1_4/lib/libapr-0.dylib -lresolv -lpthread
-L/usr/local/subversion_1_1_4/lib -lz -lc -install_name
/usr/local/subversion_1_1_4/lib/libsvn_ra_dav-1.0.dylib
-compatibility_version 1 -current_version 1.0
/Volumes/Dokumente/Dokumente/Downloads/subversion/ac-helpers/install-sh
-c .libs/libsvn_ra_dav-1.0.0.0.dylibT
/usr/local/subversion_1_1_4/lib/libsvn_ra_dav-1.0.0.0.dylib
(cd /usr/local/subversion_1_1_4/lib && rm -f libsvn_ra_dav-1.0.dylib &&
ln -s libsvn_ra_dav-1.0.0.0.dylib libsvn_ra_dav-1.0.dylib)
(cd /usr/local/subversion_1_1_4/lib && rm -f libsvn_ra_dav-1.dylib &&
ln -s libsvn_ra_dav-1.0.0.0.dylib libsvn_ra_dav-1.dylib)
/Volumes/Dokumente/Dokumente/Downloads/subversion/ac-helpers/install-sh
-c .libs/libsvn_ra_dav-1.lai
/usr/local/subversion_1_1_4/lib/libsvn_ra_dav-1.la
/Volumes/Dokumente/Dokumente/Downloads/subversion/ac-helpers/install-sh
-c .libs/libsvn_ra_dav-1.a
/usr/local/subversion_1_1_4/lib/libsvn_ra_dav-1.a
ranlib /usr/local/subversion_1_1_4/lib/libsvn_ra_dav-1.a
chmod 644 /usr/local/subversion_1_1_4/lib/libsvn_ra_dav-1.a
----------------------------------------------------------------------
Libraries have been installed in:
    /usr/local/subversion_1_1_4/lib

If you ever happen to want to link against installed
<snip>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Apr 22 13:05:19 2005

This is an archived mail posted to the Subversion Dev mailing list.