[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Windows and zlib 1.2.2

From: D.J. Heap <dj_at_shadyvale.net>
Date: 2005-04-19 02:35:58 CEST

Is zlib 1.2.2 a new requirement now? I upgraded it and can build
Subversion fine, but can't build Apache -- mod_deflate is directly using
.c files that are no longer in zlib 1.2.2, it appears.

If I downgrade to zlib 1.1.4 then Apache builds but Subversion doesn't
because it is depending on a makefile that comes with 1.2.2.

How are others building? Separate installs of zlib? 1.1.4 for Apache
and 1.2.2 for Subversion?

Also, if I try to gen-make.py without zlib at all I still get a zlib
project that fails to build.

I have no problem moving requirements up to zlib 1.2.2, I'm just trying
to get a handle on new dependencies, etc.

DJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Apr 19 02:36:48 2005

This is an archived mail posted to the Subversion Dev mailing list.