"Peter N. Lundblad" <peter@famlundblad.se> writes:
> Rename this to svn_path_check_valid and drop the above one. INvalid paths
> are really not expected very often, so there is no point in cluttering the
> API with an extra function that just returns a boolean. Also, drop the
> UTF8 check in this function. Nearly all our APIs that take strings expect
> valid UTF8. Idally the servers should check *all* strings that are
> expected to be in UTF8 as a means of input validation. That's not unique
> to paths. Exporting the UTF8 validation, as you do later in the patch, is
> a good idea for this purpose.
Oh -- I hadn't read all of Peter's comments when I wrote my long reply
just now. (I probably should have read Peter's post carefully first.)
I basically agree with everything Peter and Philip have said. My main
point was just to reserve the name 'svn_path_is_valid' for a true
boolean function. Peter's point about there being no special need for
paths to test UTF8-ness is a good one.
I don't know why I thought the the no_control_chars() function needed
a public interface. It doesn't really even need an internal
interface, it can just be part of svn_path_check_valid(). All we need
to do is loop and check for control chars. Much simpler :-).
-Karl
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Dec 10 23:02:25 2004