[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Fwd: Re: 1.1.1 make fails on solaris 5.8 (expat)]

From: anton <anton_at_nezzwerk.com>
Date: 2004-11-30 18:45:12 CET

(originally posted on users mailing list last friday)

-anton

-------- Original Message --------
Subject: Re: 1.1.1 make fails on solaris 5.8 (expat)
Date: Tue, 30 Nov 2004 00:15:09 -0500
From: anton <anton@nezzwerk.com>
To: users@subversion.tigris.org
References: <41A7BCF0.8080600@nezzwerk.com>

any comments on this?

seems like the issue is described in these bug reports:
http://subversion.tigris.org/issues/show_bug.cgi?id=699
http://subversion.tigris.org/issues/show_bug.cgi?id=1016

should i append the info below to one of the bug reports above?

thank you.

-anton

anton wrote:
> SunOS 5.8 Generic_117000-05 sun4u sparc SUNW,Ultra-4
> zlib-1.2.2
> openssl-0.9.7e
> gcc-3.4.2
> libiconv-1.8
> autoconf-2.59
> perl-5.8.5
> libtool-1.5
> python-2.3.3
> expat-1.95.5
> apache-2.0.52
>
>
> make blows up with the following:
>
> /bin/bash ../libtool --quiet --mode=link gcc -L/opt/OpenSSL/lib
> -L/usr/local/lib -rpath /opt/Svn/lib -version-info 24:7:0 -o libneon.la
> ne_request.lo ne_session.lo ne_basic.lo ne_string.lo ne_uri.lo
> ne_dates.lo ne_alloc.lo ne_md5.lo ne_utils.lo ne_socket.lo ne_auth.lo
> ne_cookies.lo ne_redirect.lo ne_compress.lo ne_207.lo ne_xml.lo
> ne_props.lo ne_locks.lo ne_acl.lo ne_openssl.lo -lssl -lcrypto -lnsl
> -lsocket -lz
> /export/home/anton/software/src/subversion-1.1.1/apr-util/xml/expat/lib/libexpat.la
>
> libtool: link: cannot find the library
> `/export/home/anton/software/src/subversion-1.1.1/apr-util/xml/expat/lib/libexpat.la'
>
> make[2]: *** [libneon.la] Error 1
> make[2]: Leaving directory
> `/export/home/anton/software/src/subversion-1.1.1/neon/src'
> make[1]: *** [subdirs] Error 2
> make[1]: Leaving directory
> `/export/home/anton/software/src/subversion-1.1.1/neon'
> make: *** [external-all] Error 1
>
>
> according to config.log in
> /export/home/anton/software/src/subversion-1.1.1/neon, invocation
> command line was:
>
> /export/home/anton/software/src/subversion-1.1.1/neon/configure
> --with-apxs=/opt/apache2/bin/apxs --without-berkeley-db
> --prefix=/opt/Svn --with-zlib --enable-shared --disable-mod-activation
> --with-ssl --with-libs=/opt/OpenSSL:/usr/local --cache-file=/dev/null
> --srcdir=/export/home/anton/software/src/subversion-1.1.1/neon
> --enable-shared
> --with-expat=/export/home/anton/software/src/subversion-1.1.1/apr-util/xml/expat/lib/libexpat.la
>
>
> path
> /export/home/anton/software/src/subversion-1.1.1/apr-util/xml/expat/lib/libexpat.la
> does not exist
>
> i have installed SMCexpat package from sunfreeware (1.95.5) - see the
> list of packages used above
>
> this is the script i run to configure and make svn:
>
> ----------------------------------------
> APACHE_HOME=/opt/apache2
> SSL_HOME=/opt/OpenSSL
> Z_LIB=/usr/local
>
> ./autogen.sh && \
> ./configure \
> --with-apxs=$APACHE_HOME/bin/apxs \
> --without-berkeley-db \
> --prefix=/opt/Svn \
> --with-zlib \
> --enable-shared \
> --disable-mod-activation \
> --with-ssl \
> --with-libs=$SSL_HOME:$Z_LIB && \
> make && \
> make check
> ----------------------------------------
>
>
> i have tried pointing to apache's apu-config and apr-config, passing
> --with-expat=/usr/local or --with-expat=/usr/local/lib or
> --with-expat=/usr/local/lib/libexpat.la or --with-expat=/opt/apache2 or
> --with-expat=/opt/apache2/lib or
> --with-expat=/opt/apache2/lib/libexpat.la (using the configure script
> above) - it fails each time (although the paths do exist).
>
> apache was built using the following script:
>
> ----------------------------------------
> SSL_BASE=/opt/OpenSSL
> LIBS=/usr/lib/libC.so.5
> CFLAGS=-fPIC
>
> ./configure \
> --with-ssl=/opt/OpenSSL \
> --with-z=/usr/local/lib \
> --prefix=/opt/apache2 \
> --with-mpm=worker \
> --enable-nonportable-atomics \
> --disable-include \
> --disable-env \
> --disable-autoindex \
> --disable-asis \
> --disable-negotiation \
> --disable-imap \
> --disable-actions \
> --disable-userdir \
> --enable-modules="access alias auth cgid dir headers log_config mime
> setenvif so status" \
> --enable-mods-shared="rewrite autoindex ssl dav deflate proxy proxy-http
> proxy-connect" \
> && make
> ----------------------------------------
>
>
> this is a snippet from the Makefile in
> /export/home/anton/software/src/subversion-1.1.1/neon/src:
>
> ----------------------------------------
> # Flags
> CPPFLAGS = -DHAVE_CONFIG_H -I/opt/OpenSSL/include -I/usr/local/include
> -I/export/home/anton/software/src/subversion-1.1.1/apr-util/xml/expat/lib
> CFLAGS = -g -O2 -I${top_builddir} -DNEON_ZLIB -DNEON_SSL
> LDFLAGS = -L/opt/OpenSSL/lib -L/usr/local/lib
> NEON_LINK_FLAGS = -version-info 24:7:0
> # Note: don't substitute in here; during a bundled
> # build of this directory, may include -lneon.
> LIBS = -lssl -lcrypto -lnsl -lsocket -lz
> /export/home/anton/software/src/subversion-1.1.1/apr-util/xml/expat/lib/libexpat.la
>
> ----------------------------------------
>
> now, when make fails, i can go in and manually replace the two lines
> above with:
>
> ----------------------------------------
> CPPFLAGS = -DHAVE_CONFIG_H -I/opt/OpenSSL/include -I/usr/local/include
> -I/usr/local/lib
> -I/export/home/anton/software/src/subversion-1.1.1/apr-util/xml/expat/lib
> LIBS = -lssl -lcrypto -lnsl -lsocket -lz /usr/local/lib/libexpat.la
> ----------------------------------------
>
> then rerun make from the subversion root directory - and it will work
> just fine.
>
> perhaps there is a better way to configure neon via the main configure
> script without resorting to this?
>
> thank you.
>
> -a
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Nov 30 18:46:26 2004

This is an archived mail posted to the Subversion Dev mailing list.