[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

BUG: Segmentation fault during checkout

From: Lukas Lipavsky <lukas.lipavsky_at_gmail.com>
Date: 2004-11-30 16:40:50 CET

I sent it to users and received no response. Now I compiled with
correct Berkeley DB (4.2.52 patch 1 and 2). It passed make check
also...

same version of svn as before (see below):

problem is exactly the same!!!

I've published the core (with Berkeley DB 4.2.52) here:
http://urtax.ms.mff.cuni.cz/~lilu/core2

here is my instalation script (I usualy have all packages in
/home/lilu/local/src and run this script from the same dir):
---BEGIN SCRIPT---
#svn instalation into /home/lilu/local

#Berkeley DB
tar xzf db-4.2.52.tar.gz
cd db-4.2.52

#patch it
cp ../patch.4.2.52.* .
patch -p0 < patch.4.2.52.1
patch -p0 < patch.4.2.52.2

#build it
cd build_unix/
../dist/configure --prefix=/home/lilu/local
make
make install
cd ../..

#svn install
tar xjf subversion-1.1.1.tar.bz2
cd subversion-1.1.1

export LD_LIBRARY_PATH=/home/lilu/local/lib
export LD_RUN_PATH=$LD_LIBRARY_PATH
export LDFLAGS=" -L/home/lilu/local/lib -l db-4.2 "
export CFLAGS=" -L/home/lilu/local/lib -l db-4.2 "

./configure --with-berkeley-db="/home/lilu/local/include:/home/lilu/local/lib"
--prefix=/home/lilu/local --without-neon --with-editor=/usr/bin/vi
--with-zlib

make

#make check #about 30 minutes!!!

make install

#PATH is set correctly so it always searches /home/lilu/local/bin first
---END SCRIPT---

current details:
ldd /home/lilu/local/bin/svn
        libsvn_client-1.so.0 =>
/home/lilu/local/lib/libsvn_client-1.so.0 (0x40016000)
        libsvn_wc-1.so.0 => /home/lilu/local/lib/libsvn_wc-1.so.0 (0x40038000)
        libsvn_ra-1.so.0 => /home/lilu/local/lib/libsvn_ra-1.so.0 (0x4005d000)
        libsvn_diff-1.so.0 => /home/lilu/local/lib/libsvn_diff-1.so.0
(0x40060000)
        libsvn_ra_local-1.so.0 =>
/home/lilu/local/lib/libsvn_ra_local-1.so.0 (0x40066000)
        libsvn_repos-1.so.0 =>
/home/lilu/local/lib/libsvn_repos-1.so.0 (0x4006b000)
        libsvn_fs-1.so.0 => /home/lilu/local/lib/libsvn_fs-1.so.0 (0x40081000)
        libsvn_fs_fs-1.so.0 =>
/home/lilu/local/lib/libsvn_fs_fs-1.so.0 (0x40087000)
        libsvn_fs_base-1.so.0 =>
/home/lilu/local/lib/libsvn_fs_base-1.so.0 (0x4009d000)
        libsvn_ra_svn-1.so.0 =>
/home/lilu/local/lib/libsvn_ra_svn-1.so.0 (0x400bd000)
        libsvn_delta-1.so.0 =>
/home/lilu/local/lib/libsvn_delta-1.so.0 (0x400cb000)
        libsvn_subr-1.so.0 => /home/lilu/local/lib/libsvn_subr-1.so.0
(0x400d3000)
        libaprutil-0.so.0 => /home/lilu/local/lib/libaprutil-0.so.0 (0x400f7000)
        libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x4011f000)
        libdb-4.2.so => /home/lilu/local/lib/libdb-4.2.so (0x40125000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x401e5000)
        libapr-0.so.0 => /home/lilu/local/lib/libapr-0.so.0 (0x40204000)
        librt.so.1 => /lib/librt.so.1 (0x40225000)
        libm.so.6 => /lib/libm.so.6 (0x40237000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x4025b000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x40288000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4029d000)
        libdl.so.2 => /lib/libdl.so.2 (0x402ee000)
        libz.so.1 => /usr/lib/libz.so.1 (0x402f1000)
        libc.so.6 => /lib/libc.so.6 (0x402fe000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

If you have anymore questions, ask

Lukas

---------- Forwarded message ----------
From: Lukas Lipavsky <lukas.lipavsky@gmail.com>
Date: Mon, 29 Nov 2004 22:20:28 +0100
Subject: Segmentation fault during checkout
To: users@subversion.tigris.org

Hi, I'am running svn 1.1.1 (r11581) on Linux(slackware linux 9.1).

I am using FSFS (not BerkeleyDB) and for access I use svn+ssh

When checkout most small projects, everything seems fine. But I tried
subversion sorces from my own repository (just in case of testing):

on server:
svnadmin create --fs-type=fsfs /home/lilu/test
svn import -m "init" subversion-1.1.1 file:///home/lilu/test/svn

That's all fine.

When I checkout (without ssh tunnel)
svn checkout file:///home/lilu/test/svn
it FAILS (Segmentation Fault, core dumped)

It always happens when dowloading the
svn/subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/tests
(last downloaded correctly is
svn/subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/OutputInterface.java)

I've published the core here:
http://urtax.ms.mff.cuni.cz/~lilu/core

If I run through ssh tunnel, it writes:
svn: Network connection closed unexpectedly
svn: Connection closed unexpectedly
which I thing someone posted here under the subject Problem using
svn+ssh:// on Windows NT

some details:

ldd /usr/local/bin/svn
       libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x40027000)
       libdb-4.3.so => /usr/local/BerkeleyDB.4.3/lib/libdb-4.3.so (0x4002e000)
       libexpat.so.0 => /usr/lib/libexpat.so.0 (0x4015d000)
       librt.so.1 => /lib/librt.so.1 (0x4017c000)
       libcrypt.so.1 => /lib/libcrypt.so.1 (0x4018e000)
       libnsl.so.1 => /lib/libnsl.so.1 (0x401bb000)
       libdl.so.2 => /lib/libdl.so.2 (0x401d0000)
       libxml2.so.2 => /usr/lib/libxml2.so.2 (0x401d4000)
       libpthread.so.0 => /lib/libpthread.so.0 (0x402ce000)
       libm.so.6 => /lib/libm.so.6 (0x4031f000)
       libz.so.1 => /usr/lib/libz.so.1 (0x40342000)
       libc.so.6 => /lib/libc.so.6 (0x4034f000)
       libimf.so => /opt/intel_cc_80/lib/libimf.so (0x40485000)
       /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Thanks in advance

Lukas

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Nov 30 16:42:01 2004

This is an archived mail posted to the Subversion Dev mailing list.