[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

undefined reference when compiling on cygwin

From: Colin JN Breame <colin_at_breame.com>
Date: 2004-10-25 00:30:58 CEST

Hello,

I have a new installation of cygwin and version 1.1.1 of subversion.

$ configure --prefix=/usr
...
$ make
cd subversion/libsvn_subr && /bin/bash
/home/Colin/src/subversion-1.1.1/libtool --silent --mode=link gcc -g
-O2 -DNEON_ZLIB -DNEON_SSL -rpath /usr/lib -o libsvn_subr-1.la
-no-undefined auth.lo cmdline.lo config.lo config_auth.lo config_file.lo
config_win.lo date.lo error.lo hash.lo io.lo md5.lo opt.lo path.lo
pool.lo quoprint.lo sorts.lo stream.lo subst.lo svn_base64.lo
svn_string.lo target.lo time.lo utf.lo utf_validate.lo validate.lo
version.lo xml.lo /usr/lib/libaprutil-0.la -lgdbm -ldb-4.2 -lexpat
-liconv /usr/lib/libapr-0.la -lcrypt -lintl
/usr/lib/libcygwin.a(libcmain.o)(.text+0x7d): undefined reference to
`_WinMain@16'
collect2: ld returned 1 exit status
make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1

I'm using the cygwin distribution of neon, apr and apr-util.

Any ideas what might be going wrong here?

Colin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Oct 25 00:31:18 2004

This is an archived mail posted to the Subversion Dev mailing list.