[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Issue #997 - libtool: link: only absolute run-paths are allowed

From: Kurt Guenther <kurtg_at_serent.com>
Date: 2004-07-06 03:23:19 CEST

Are there any workarounds for this one?

I have the source code for:

/opt/httpd-2.0.50
/opt/subversion-1.0.5

I build http with:

   ./configure --enable-dav --enable-dav-fs

and it all compiles and installs fine.

I then configure & make subversion:

   ./configure --with-apache=/opt/httpd-2.0.50
   make

but it ends with this error:

cd subversion/mod_authz_svn && /bin/sh /opt/subversion-1.0.5/libtool
--silent --mode=link gcc -g -O2 -g -O2 -pthread -DNEON_ZLIB -rpath
-avoid-version -module -o mod_authz_svn.la mod_authz_svn.lo
../../subversion/libsvn_subr/libsvn_subr-1.la
libtool: link: only absolute run-paths are allowed
make: *** [subversion/mod_authz_svn/mod_authz_svn.la] Error 1

I'm running with Gentoo Linux on a 2.6 kernel, but I don't know why that
would be a problem. Gcc version is:

seeker subversion-1.0.5 # gcc --version
gcc (GCC) 3.3.3 20040412 (Gentoo Linux 3.3.3-r6, ssp-3.3.2-2, pie-8.7.6)

--Kurt

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Jul 6 04:03:11 2004

This is an archived mail posted to the Subversion Dev mailing list.