[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] svn_load_dirs update

From: Blair Zajac <blair_at_orcaware.com>
Date: 2004-01-17 05:16:04 CET


I committed part of this patch minus the modifications to the
get_yes_or_no subroutine in revision 8357.

I think I'd rather have some other way of indicating a yes to all
answer. Part of the issue is that you can say 'a' to the very
first question that the program asks and it'll answer yes from
then on until $yes_to_all is reset to 0.

I would prefer the following:

1) Rename get_yes_or_no to something like get_answer.
2) Have get_answer take a list of valid responses and
   say the default response, and a mapping from typed
   response to the value that get_answer should return.


Blair Zajac <blair@orcaware.com>
Plots of your system's performance - http://www.orcaware.com/orca/
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Jan 17 05:16:35 2004

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.