[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Please change name of svn_repos_authz_read_func_t

From: Greg Hudson <ghudson_at_MIT.EDU>
Date: 2003-12-24 21:53:28 CET

Back when Karl and Ben were adding the read authz hook to
svn_repos_delta_dirs, I made a request of Karl (I think; conceivably
it was Ben) on IRC to change the name of the type from
svn_repos_authz_read_func_t to svn_repos_authz_func_t so that it could
be reused in the commit editor for write authorization, at some later
time. (There's nothing read-specific about the authorization function
signature.) He agreed, but I just noticed that the type name never
got changed.

To repair this oversight, I'd like to request that Karl or Ben compose
a patch to rename the type and enter it as a 1.0 candidate.

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Dec 24 21:54:03 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.