[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Seruious problems with APU_WANT_DB

From: Branko Čibej <brane_at_xbc.nu>
Date: 2003-10-31 09:22:41 CET

Russell Yanofsky wrote:

>Sander Striker wrote:
>
>
>>...
>>
>>It was my patch, so I'll fix it (unless someone beats me to it). What
>>about expanding the --with-berkeley-db option to gen-make.py to set up
>>INCLUDES correctly?
>>
>>
>
>Assuming you're talking about rev 7560, wouldn't reverting these changes:
>
>-#include <db.h> /* Berkeley DB interface */
>+#define APU_WANT_DB
>+#include <apu_want.h>
>
>fix the problem and be more correct? APU_WANT_* appears to be a mechanism
>for including optional functionality that might not be available. But to the
>fs library, BDB isn't optional functionality. The filesystem library should
>include db.h or die trying.
>
>
No, it wouldn't be right. On Unix, apr-util's configury knows how to
find BDB, and Subversion now uses whatever apr-util finds. That's goodness.

-- 
Brane Čibej   <brane_at_xbc.nu>   http://www.xbc.nu/brane/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Oct 31 09:23:21 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.