[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Compiling problem on SunOS 5.8

From: E.L. Willighagen <egonw_at_sci.kun.nl>
Date: 2003-10-10 15:09:39 CEST

On Friday 10 October 2003 14:56, Michael S wrote:
> E.L. Willighagen wrote:
> > started using SV yesterday using the Debian debs... and it worked great.
> > Thus tried to compile it at work for SunOS 5.8 too, but it failed with
> > (only tail):
>
> [snip]
>
> > /vol/acfiles7/egonw/tmp/subversion-0.31.0/apr/.libs/libapr-0.so:
> > undefined reference to `pthread_mutexattr_setrobust_np'
> > /vol/acfiles7/egonw/tmp/subversion-0.31.0/apr/.libs/libapr-0.so:
> > undefined reference to `pthread_mutex_consistent_np'
> > collect2: ld returned 1 exit status
> > gmake: *** [subversion/clients/cmdline/svn] Error 1
> >
> > I've downloaded 0.31.0 and db-4.1.25.zip from the website mentioned at
> > your website, and copied that dir as db/ in the top SV dir...
>
> [snip]
>
> I believe the answer to your question is here:
> http://www.contactor.se/~dast/svnusers/archive-2003-09/0063.shtml
>
> I had hoped, that this problem was fixed, but I guess the package
> manager still uses his old libtool...

Thanx! That seems to make it go.

Egon

-- 
egonw@sci.kun.nl
PhD on Molecular Representation in Chemometrics
Nijmegen University
http://www.cac.sci.kun.nl/people/egonw/
GPG: 1024D/D6336BA6
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Oct 10 15:13:27 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.