[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: sub-configures for 0.28 generated by old autoconf (2.13)

From: Philip Martin <philip_at_codematters.co.uk>
Date: 2003-08-28 18:04:43 CEST

kfogel@collab.net writes:

> Weird! We require Autoconf 2.50 or higher, right here in
> configure.in:
> dnl Ensure that subversion is configured with autoconf 2.50 or newer
> dnl Don't even think about removing this check!
> AC_PREREQ(2.50)
> What happened? How come this check didn't flag an error for Paul?
> Paul, did you do something fancy?

Debian has a system that allows both 2.50 and 2.13 to be installed
simultaneously, and then plain "autoconf" is a wrapper that guesses
which real version of autoconf is required. Last time I used it the
wrapper deduced that Subversion required 2.50, but it fell back to
2.13 for apr/apr-util since there is no indication that they needed or
supported 2.50.

Philip Martin
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Aug 28 18:05:38 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.