[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] eliminate -noproxy flag to SWIG

From: Greg Stein <gstein_at_lyra.org>
Date: 2003-05-13 00:07:22 CEST

On Mon, May 12, 2003 at 03:03:30PM -0500, cmpilato@collab.net wrote:
> So, there are some "action items" contained in this little exchange.
> Let's clear up the other ones:
> - naming schemes -- do we agree that the old fs.py renaming stuff
> sucks, so go back to using the full function names?

The 'svn_fs_' prefix is redundant with 'svn.fs.'. That's why I eliminated
that portion in the first place.

I think if the prefix elimination is done consistently, then it would be
quite nice. Of course, util.i is the hairball here. Maybe the functions in
there just eliminate the 'svn_' prefix?

> - headers-to-modules ratio -- we'd like to see each header
> handled by its own module, right?

Nope. There is a definite cost to having a billion little extension modules.
That is why a number of them are pulled into the util.i module.

If I had my druthers, there would be just a single extension module. As it
is, I divided them along some probable use-case lines. (and also along the
dividing line of "will the FS library be around, or will the module only be
used client-side?")

> > > There's only one thing I'm not very fond of, and that's the
> > > %pythoncode {} blocks which now house the old contents of the *.py
> > > wrapper scripts we had.
> >
> > Yeah, I agree, it's ugly.


> > > The other is to keep our bindings pure, with _fs.so and fs.py, and
> > > then any wrapper code we do lives in modules with names like
> > > FileDiff.py, WorkingCopy.py, etc.

Let's avoid too many Python modules, please. One of the things that I really
detest about Java is the one-class-one-file approach.

Again, this is why some of the FS-related utilities were placed into the
fs.py module, and why the Editor class was placed into delta.py. The
functional grouping cuts along the lines of additional layers and the
underlying function wrappers.

> > > I guess what I'm getting at is that it's yucky to have our .i files
> > > growing into these massive sourcefiles with concatenating
> > > language-specific wrapper code for python, perl, java, ruby, etc. just
> > > slapped into %python-et-all-code {} blocks.

Right, agreed.


Greg Stein, http://www.lyra.org/
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue May 13 00:06:23 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.