[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Is SVN on Apache 1.3.27 Out of the Question

From: Greg Stein <gstein_at_lyra.org>
Date: 2003-04-16 20:11:19 CEST

On Wed, Apr 16, 2003 at 10:32:30AM -0400, Garrett Rooney wrote:
> Richard In Public wrote:
>
> >Hi
> >
> >I'd really like to run a Subversion service on a 3rd party server.
> >Unfortunately, my otherwise excellent service provider runs Apache 1.3.27.
> >I know that Subversion should be used with an up to date 2.0 server, but I
> >thought I'd check just in case. So, is it at all possible to run
> >Subversion
> >on such a server?
> >
> >
>
> no, it is not. you could still use subversion via ra_svn, either by
> running a stand along svnserve daemon, or by tunneling it over ssh, but
> there is no way to run mod_dav_svn with anything but apache 2.0.

Yup. And the differences in technology between Apache 1.3's mod_dav and
Apache 2.0's mod_dav (i.e. their pluggability) would be a serious impediment
towards back-porting mod_dav_svn.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Apr 16 20:11:45 2003

This is an archived mail posted to the Subversion Dev mailing list.