[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: busted 'make swig-py'...

From: Ben Collins-Sussman <sussman_at_collab.net>
Date: 2003-02-28 19:10:11 CET

Greg Stein <gstein@lyra.org> writes:

> > But I know nothing about our swig build system. Just thought I'd
> > throw this problem out there, because I wasted a lot of time before I
> > thought of running 'gmake swig-py'. :-)
>
> You've got something funny going on, because I certainly don't see any
> thing in our rules that would be gmake specific.

Ah, but there really is a build-system bug here somewhere. Here's my
reproduction recipe. I wonder if Garrett or other FreeBSD users can
reproduce as well:

I have a FreeBSD 4.7 system with autoconf 2.53, libtool 1.4.3, and the
httpd/apr/apr-util 2.0.44 release installed.

$ svn co http://svn.collab.net/repos/svn/trunk svn
[...checked out revision 5153]
$ cd svn
$ ./autogen.sh; ./configure --enable-maintainer-mode
$ make && make install
$ make swig-py
/usr/local/bin/swig -c -python -noproxy -I/home/sussman/projects/svn2/subversion/bindings/swig -I/home/sussman/projects/svn2/subversion/include -I/usr/local/apache2/include -I/usr/local/include/python2.2 -o subversion/bindings/swig/python/svn_client.c
Must specify an input file. Use -help for available options.
*** Error code 1

And here's what I discovered: if I now run 'gmake swig-py', everything
works. And then *afterwards*, plain old 'make swig-py' works for me!

Anyone have any ideas? Wanna see my generated build files?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Feb 28 17:11:15 2003

This is an archived mail posted to the Subversion Dev mailing list.