[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: 4270 build problems: `APR_FILEPATH_ENCODING_UTF8' undeclared?

From: Sander Striker <striker_at_apache.org>
Date: 2003-01-06 17:06:09 CET

> From: John J. Trammell [mailto:trammell+subversion@el-swifto.com]
> Sent: Monday, January 06, 2003 5:03 PM

> Hey all:
>
> I'm following the INSTALL instructions for bootstrapping, and
> come across the following:
>
> ../svn-trunk/subversion/libsvn_subr/io.c: In function
> `get_path_encoding':
> ../svn-trunk/subversion/libsvn_subr/io.c:68:
> `APR_FILEPATH_ENCODING_UTF8' undeclared (first use in this functio
> n)
> ../svn-trunk/subversion/libsvn_subr/io.c:68: (Each undeclared
> identifier is reported only once
> ../svn-trunk/subversion/libsvn_subr/io.c:68: for each function it
> appears in.)
> make[1]: *** [subversion/libsvn_subr/io.lo] Error 1
>
> System is i386 Debian/woody, svn "release" is 3987, apache is 2.0.43.
> The build of r3987 went well, and the fetch, autogen, & config of the
> trunk went without remark. Is this problem pilot error, or a known
> issue? Or something else? I've searched the mailing list archives,
> no joy.

Known issue. Since rev 4239, thus quite recent, we require that you
build against APR HEAD.

Sander

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Jan 6 17:07:00 2003

This is an archived mail posted to the Subversion Dev mailing list.