[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Apache release compatibility, WAS: RE: svn commit: rev 4239 - trunk/subversion/libsvn_subr

From: Karl Fogel <kfogel_at_newton.ch.collab.net>
Date: 2003-01-03 22:02:11 CET

Justin Erenkrantz <jerenkrantz@apache.org> writes:
> Note that stable httpd will not be able to use APR 1.0 though -
> because the current plan is that we're going to drop all deprecated
> functions at that branch point - httpd 2.0.x will be fixed at the
> moment right before APR 1.0 is released.
>
> That's going to be interesting from the Subversion perspective though.
> We may be forced *not* to use APR 1.0 because httpd-2.0 won't work
> with it. It's fun, isn't it? Perhaps we'll relax this policy and not
> drop deprecated functions until APR 2.0, but that's an awful lot of
> cruft to keep around for a long time. -- justin

It may be moot, because we'll probably need to use http-2.1.x series
anyway, due to mod_dav changes (and who knows what else, by then).

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Jan 3 22:45:59 2003

This is an archived mail posted to the Subversion Dev mailing list.