[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 4239 - trunk/subversion/libsvn_subr

From: Justin Erenkrantz <jerenkrantz_at_apache.org>
Date: 2003-01-03 18:15:41 CET

--On Friday, January 3, 2003 9:53 AM -0600 Ben Collins-Sussman
<sussman@collab.net> wrote:

> If I submit a patch to mod_dav which *changes* the mod_dav API, do
> you really think that will be accepted into the httpd 2.0 branch?
> I've been assuming not. So Subversion will need to follow 2.1 for
> a while, I suspect.
>
> Am I wrong about this?

No, I think you're right.

While we're straightening out the problem, we're certainly going to
be tweaking httpd-2.1 not httpd-2.0. I would imagine we implement
the corresponding changes to mod_dav_svn on a branch to svn itself to
shield our users as long as possible from this dependency.

However, once the problem is completely identified and fixed, we
should be able to see whether we can backport it to the 2.0 series.
I think we will be able to leverage the provider API with the
versioning bits to make mod_dav backwards-compatible. It won't be
pretty though, but that's why I hate backports. And, I won't
guarantee that it can happen, either. Any backports to httpd-2.0
must maintain complete binary compatibility. -- justin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Jan 3 18:16:28 2003

This is an archived mail posted to the Subversion Dev mailing list.