[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: can't create valid repositry

From: Branko Čibej <brane_at_xbc.nu>
Date: 2002-12-16 04:40:49 CET

shivaken wrote:

>Hi
>
>Sorry, I forgot. I tried r3200, r3578, r3987.
>
There was at least one database schema change during that time, I think.

>And, I installed them with --prefix=/usr.
>
>So, svnadmin and svn must be the same version.
>
I fail to see how you came to this conclusion.

>>Which version of Subversion?
>>
>>Are you using svnadmin and svn from the same Subversion version?
>>
>>Does this work
>>
>>$ svnadmin create foo
>>$ svnlook youngest foo
>>$ svn co file://`pwd`/foo wc
>>
Well, have you tried this recipe? The problem you report looks very much
like a schema mismatch, implying that your svnadmin and your svn are
from different versions.

BTW, why don't we have svnadmin --version?

-- 
Brane Čibej   <brane_at_xbc.nu>   http://www.xbc.nu/brane/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Dec 16 04:41:27 2002

This is an archived mail posted to the Subversion Dev mailing list.