[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Still having problems compiling 0.16.

From: Sander Striker <striker_at_apache.org>
Date: 2002-12-05 20:24:20 CET

> From: Mark G [mailto:mark@nolab.conman.org]
> Sent: 05 December 2002 20:17

>
> On 5 Dec 2002, Ben Collins-Sussman wrote:
>
> > I'm going to try and answer this FAQ once and for all. After talking
> > with sabi and sander in IRC, here's the problem:
> >
> > * the apache 2.0.43 has some bogus libtool cruft in it. the
> > ltmain.sh scripts it contains need to be tossed.
>
> Okay. BTW: That isn't in the FAQ document I found:
>
> http://subversion.tigris.org/project_faq.html
>
> Since a lot of people want to use the released Apache and not the CVS head
> this will probably be pretty common.

No. It was a flubbup with the 2.0.43 release. The 2.0.42 release was fine,
as will the 2.0.44 one be. That shouldn't be too far away.
 
>> * the best solution is just to clean out the apache source tree:
>>
>> make distclean; ./buildconf && ./config.nice
>
> I removed the ltmain.sh files and then did buildconf and re-configured and
> it worked!
>
> BTW: There is no "distclean" target in the Apache 2.0.43 makefiles.

There should be. It is included via build/rules.mk.

> Thanks! Now I can start playing with SVN!

Have fun ;)

Sander

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Dec 5 20:25:09 2002

This is an archived mail posted to the Subversion Dev mailing list.