On Thu, 2002-12-05 at 12:09, Karl Fogel wrote:
> Yeah, the variable names in that file made a lot more sense when the
> file was named `proxies'. Now that the filename is more generic, the
> variable names need to get more specific.
>
> If you want to come up with a better scheme, while you're in there,
> I'm practically ready to +1 it in advance :-). And if we're going to
> change it, let's do it now, before we have billions of users.
Okay... I'd like to:
* Rename the existing variables:
host -> http_proxy_host
port -> http_proxy_port
username -> http_proxy_username
password -> http_proxy_password
timeout -> http_timeout
no_proxy -> no_http_proxy
(I really think dashes would be more user-friendly than underscores
in config variable names, but that gets into the realm of gratuitous
tampering.)
* Move most of the code for dealing with server groups out of
libsvn_ra_dav/session.c into libsvn_subr:
/* Enumerate the group MASTER_GROUP in CFG. Each variable value is
interpreted as a list of glob patterns (separated by comma and
optional whitespace). Return the name of the first variable whose
value matches KEY, or NULL if no variable matches.
If EXCEPTION_GROUP and EXCEPTION_VAR are set, always return NULL
if KEY matches the value of the specified variable. */
const char *svn_config_find_group (svn_config_t *cfg,
const char *master_group,
const char *key,
const char *exception_group,
const char *exception_var,
apr_pool_t *pool);
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Dec 5 19:14:15 2002