[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Can't build 0.16

From: Eric Hanchrow <offby1_at_blarg.net>
Date: 2002-12-04 21:11:23 CET

My OS is Debian 3.0, with some stuff from the "testing" distribution,
and Apache 2.0.43.
I was trying to build from the subversion-r3987 tarball.
I configured like this:

        ./configure --enable-maintainer-mode --prefix=/usr/local/svn --with-apxs=/usr/bin/apxs2

I have Berkeley DB 4.0 (the Debian pacakge is version 4.0.14-1) on my
system, but `configure' said

    checking for Berkeley DB... not found

Here's the error:

    ------ completed all in neon
    cd subversion/clients/cmdline && /bin/sh /usr/local/src/subversion-r3987/libtool --silent --mode=link gcc -g -Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -pthread -DNEON_ZLIB -Wpointer-arith -Wwrite-strings -Wshadow -DSVN_DEBUG -DAP_DEBUG -rpath /usr/local/svn/lib -o svn add-cmd.o cat-cmd.o checkout-cmd.o cleanup-cmd.o commit-cmd.o copy-cmd.o delete-cmd.o diff-cmd.o export-cmd.o feedback.o help-cmd.o import-cmd.o info-cmd.o log-cmd.o ls-cmd.o main.o merge-cmd.o mkdir-cmd.o move-cmd.o prompt.o propdel-cmd.o propedit-cmd.o propget-cmd.o proplist-cmd.o props.o propset-cmd.o resolve-cmd.o revert-cmd.o status-cmd.o status.o switch-cmd.o update-cmd.o util.o ../../../subversion/libsvn_client/libsvn_client-1.la ../../../subversion/libsvn_wc/libsvn_wc-1.la ../../../subversion/libsvn_ra/libsvn_ra-1.la ../../../subversion/libsvn_delta/libsvn_delta-1.la ../../../subversion/libsvn_subr/libsvn_subr-1.la /usr/local/src/subversion-r3987/apr-util/libaprutil-0
 .la -lgdbm -lexpat /usr/local/src/subversion-r3987/apr/libapr-0.la -lm -lcrypt -lnsl -ldl /usr/local/src/subversion-r3987/neon/src/libneon.la -L/usr/local/svn/lib -lz -lxml2
    /usr/bin/ld: warning: libc.so.4, needed by /usr/local/src/subversion-r3987/apr-util/.libs/libaprutil-0.so, not found (try using -rpath or -rpath-link)
    /usr/local/src/subversion-r3987/apr/.libs/libapr-0.so: undefined reference to `___toupper'

(I've deleted a few other "undefined reference" lines)

I can't imagine why it's looking for libc.so.4. Isn't that a very old version?

-- 
PGP Fingerprint: 3E7B A3F3 96CA 8958 ACC5  C8BD 6337 0041 C01C 5276
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Dec 4 21:12:17 2002

This is an archived mail posted to the Subversion Dev mailing list.