[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] svn-config installedness test fails when symlinked

From: Branko Čibej <brane_at_xbc.nu>
Date: 2002-09-12 21:57:56 CEST

Marcus Comstedt wrote:

>=?UTF-8?B?QnJhbmtvIMSMaWJlag==?= <brane@xbc.nu> writes:
>
>
>
>>No changes are necessary in gen[-_]make.py. Try this patch, and don't
>>forget to fill in the necessary magic in INSTALL_SVN_CONFIG:
>>
>>
>
>
>Thanks Brane. Here's a new, better patch. It also fixes another bug,
>which is that the subversion-1 directory wasn't added to the -I list
>produced by --includes.
>
>There is still a rather big misfeature in that if you build apr, neon,
>and bdb inside the subversion tree, you get references to the builddir
>even after subversion is installed. (That's not my fault, it was like
>that before.)
>
>
> // Marcus
>
>
>* svn-config.in:
> Use a flag to select installed mode rather than trying to auto-detect.
> (--includes): Added $includedir/subversion-1 to list of includes.
>
>* Makefile.in, build.conf, configure.in:
> Added special installation procedure for svn-config, which sets the
> "installed" flag.
>
>

This patch looks fine. As far as I'm concerned, it can go in ... except,
what about $DESTDIR? Is Subversion expected to actually work out of
$DESTDIR, or is that just a staging area for packaging?

-- 
Brane Čibej   <brane_at_xbc.nu>   http://www.xbc.nu/brane/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Sep 12 21:58:43 2002

This is an archived mail posted to the Subversion Dev mailing list.