[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 3151 - clients/rapidsvn/trunk/src/tests/svncpp clients/rapidsvn/trunk/src/svncpp

From: Alexander Mueller <alex_at_littleblue.de>
Date: 2002-09-11 12:28:30 CEST

Branko Čibej wrote:

> Alexander Mueller wrote:
>
>> Greg Stein wrote:
>>
>>> On Tue, Sep 10, 2002 at 10:37:55AM -0700, Brent R. Matzelle wrote:
>>>
>>>
>>>> --- Philip Martin <philip@codematters.co.uk> wrote:
>>>> ...
>>>>
>>>>
>>>>> export is a keyword in standard ISO C++ and should not be used as a
>>>>> name. Comeau's EDG-based 4.3 compiler is the only compiler I know
>>>>> of
>>>>> that supports export.
>>>>>
>>>>
>>>> Okay, since it is a keyword does anyone have any suggestions for an
>>>> alternative name? How about 'extract()', 'send()', or 'transport()'?
>>>>
>>>
>>>
>>> For things like this, the SWIG code usually recommends appending a
>>> trailing
>>> underscore:
>>>
>>> svn::export_()
>>> svn::switch_()
>>>
>>> It is visually less intrusive.
>>>
>>> Cheers,
>>> -g
>>>
>>>
>>>
>> Doesnt look bad as well. For me, "doExport" or "doSwitch" is fine.
>> Its a matter of taste.
>> Alex
>
>
>
> Or just Export and Switch; C++ is case-sensitive, right?
>
>
Hm. Personally, I dont like case mixing.
-1

Alex

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Sep 11 12:29:22 2002

This is an archived mail posted to the Subversion Dev mailing list.