[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 3151 - clients/rapidsvn/trunk/src/tests/svncpp clients/rapidsvn/trunk/src/svncpp

From: Brent R. Matzelle <bmatzelle_at_yahoo.com>
Date: 2002-09-10 20:59:26 CEST

--- Alexander Mueller <alex@littleblue.de> wrote:
> Brent R. Matzelle wrote:
>
> >--- Philip Martin <philip@codematters.co.uk> wrote:
> >
> >
> >>"Brent R. Matzelle" <bmatzelle@yahoo.com> writes:
> >>
> >>
> >>
> >>>>Isn't 'export' a keyword? How is that you can get away naming
> >>>>
> >>>>
> >>a
> >>
> >>
> >>>>function 'export'?
> >>>>
> >>>>
> >>>>
> >>>It isn't with with MSVC++ 6. Are you using gcc?
> >>>
> >>>
> >>export is a keyword in standard ISO C++ and should not be used as
> a
> >>name. Comeau's EDG-based 4.3 compiler is the only compiler I
> know
> >>of
> >>that supports export.
> >>
> >>
> >
> >Okay, since it is a keyword does anyone have any suggestions for
> an
> >alternative name? How about 'extract()', 'send()', or
> 'transport()'?
> >
> Why not just "doExport" or "performExport"?
>
> >
> >
> >One other thing. 'switch' is a reserved word so i named the
> wrapper
> >method Modify::mirror() for svn_client_switch(). Does anyone have
> an
> >issue with that?
> >
> >Brent.
> >
> And "doSwitch" or "performSwitch"?
>
> Alex
>

The "do" prefix looks concise enough for me. I'll go with that.

Regards,

Brent.

__________________________________________________
Yahoo! - We Remember
9-11: A tribute to the more than 3,000 lives lost
http://dir.remember.yahoo.com/tribute

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Sep 10 21:00:08 2002

This is an archived mail posted to the Subversion Dev mailing list.