[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 3151 - clients/rapidsvn/trunk/src/tests/svncpp clients/rapidsvn/trunk/src/svncpp

From: Karl Fogel <kfogel_at_newton.ch.collab.net>
Date: 2002-09-10 19:55:47 CEST

"Brent R. Matzelle" <bmatzelle@yahoo.com> writes:
> That defeats the purpose of the C++ namespacing. Double namespacing
> doesn't look any better than aliasing:
> svn::svn_switch() as compared to svn::mirror()
> Does the C API have to use these C++ reserved words?

Clearly it would be silly to change the user-visible command names,
and yet it would also be silly for the internal interfaces not to
match the user-visible ones whereever possible. So yes, I think
there's a compelling reason for the C API to stay the way it is.

Maybe try this: define a special prefix, "X" or something, that you
explicitly document as existing only to protect against keyword
collisions. Use it for those places in the C++ API where there's a
conflict, and never use it anywhere else: "svn::ls" but
"svn::Xswitch", and so on.

I agree that this is a bit unsightly, but changing the C API names so
that they don't match the user-visible interfaces would be far worse.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Sep 10 20:17:51 2002

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.