[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: bad database error

From: Karl Fogel <kfogel_at_newton.ch.collab.net>
Date: 2002-09-07 21:16:01 CEST

It looks like you've got an older version (2.4.14) of Berkeley DB
sitting around somewhere on your system, maybe? Have you checked the
likely places?

-K

Ken Horn <ken@DarkSideConsulting.com> writes:
> I'm running 0.14.2, on a raq (redhat 7) linux box. with the latest tar
> balls of db(4.0.14) and httpd 2.0.40.
>
> I've imported a project - and can checkout locally.
> Everything built OK as far as I can tell.
>
> However, I can't get network access working -- when accessing the
> repository via apache, the only thing shown in the browser is:
>
> bad database version: 2.4.14
>
> I have checked the db distrib, including the db version #defines in
> db.h in the distribution, and it indicates the 4.0.14 the tarball
> suggests. The apache error log shows:
>
> [Fri Sep 06 21:56:31 2002] [error] [client x.x.x.x] Could not fetch
> resource information. [500, #0], referer: http://www.xxxxx.com:9000/
> [Fri Sep 06 21:56:31 2002] [error] [client x.x.x.x] Could not open the
> SVN filesystem at /home/sites/site7/users/xx/SVN_repository [500,
> #61000], referer: http://www.xxxxxxx.com:9000/
> [Fri Sep 06 21:56:31 2002] [error] [client x.x.x.x] (84)Invalid or
> incomplete multibyte or wide character: bad database version: 2.4.14
> [500, #61000], referer: http://www.xxxxxx.com:9000/
>
> The apache server runs and all builds were done as the same user, so I
> don't see file permissions being a problem.
>
> running db_recover -v gives me:
>
> db_recover: log_get: log.00001: No such file or directory
> db_recover: appinit failed: No such file or directory
>
> The SVN_repository/db subdir contains:
> -rw-rw-rw- 1 xxx site7 1182 Sep 4 21:56 DB_CONFIG
> -rw-rw-rw- 1 xxx site7 8192 Sep 6 21:54 __db.001
> -rw-rw-rw- 1 xxx site7 270336 Sep 6 21:54 __db.002
> -rw-rw-rw- 1 xxx site7 327680 Sep 6 21:54 __db.003
> -rw-rw-rw- 1 xxx site7 712704 Sep 6 21:54 __db.004
> -rw-rw-rw- 1 xxx site7 16384 Sep 6 21:54 __db.005
> -rw-r----- 1 xxx site7 708608 Sep 6 22:17 __db_lock.share
> -rw-rw-rw- 1 xxx site7 28672 Sep 6 21:54 changes
> -rw-rw-rw- 1 xxx site7 8192 Sep 6 21:54 copies
> -rw-rw-rw- 1 xxx site7 1045386 Sep 4 22:12 log.0000000001
> -rw-rw-rw- 1 xxx site7 739377 Sep 6 21:54 log.0000000002
> -rw-rw-rw- 1 xxx site7 8192 Sep 6 21:54 nodes
> -rw-rw-rw- 1 xxx site7 8192 Sep 6 21:54 representations
> -rw-rw-rw- 1 xxx site7 8192 Sep 6 21:54 revisions
> -rw-rw-rw- 1 xxx site7 1548288 Sep 6 21:54 strings
> -rw-rw-rw- 1 xxx site7 8192 Sep 6 21:54 transactions
>
> Which suggests the db is corrupt or something, but the local checkouts
> work without error.
>
> I've tried rebuilding things, but to no avail. I'm not sure if it's a
> svn, apache or db problem. I can't find anything meaningful in either
> the db or svn mail lists.
>
> Ideas?
>
> Thanks,
>
> Ken
>
> PS Am not currently subscribed to the list, so cc'ing me on messages
> would be appreciated.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: dev-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Sep 7 21:37:35 2002

This is an archived mail posted to the Subversion Dev mailing list.