[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: "svn diff" performance

From: Ben Collins-Sussman <sussman_at_collab.net>
Date: 2002-07-24 18:51:06 CEST

Branko Čibej <brane@xbc.nu>

> Yes, and fold do_update into do_switch, if the only difference is the
> same-path assumption. Then rename that to do_update again, and use
> that everywhere, with appropriate flage.

Heh, cmpilato is fixing this bug right now. After chatting, I think
we're going for the "3 functions" approach, rather than adding more
flags to do_update() or do_switch(). It's certainly conceptually
easier to understand the code if you see

   do_update
   do_switch
   do_diff

in the RA vtable. The fact that they all share the same code under
the hood is just an implementation detail.

If we had just a single do_update, it would be a little weird that all
these callers in libsvn_client just "know" which flags to pass.
That's almost admitting that libsvn_client understands the shared
implementation, which it shouldn't.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Jul 24 18:52:54 2002

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.