[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Issue 770] Changed - python testsuite mixes up url

From: Branko Čibej <brane_at_xbc.nu>
Date: 2002-06-29 20:11:21 CEST

I'm replyting here, because I can't connect to tigris.org ...

issues@subversion.tigris.org wrote:

>http://subversion.tigris.org/issues/show_bug.cgi?id=770
>
>*** Old
>--- New
>***************
>*** 55,57 ****
>--- 55,72 ----
>
> ------- Additional Comments From kfogel@tigris.org 2002-06-28 11:28 PDT -------
> Grrr, bite-sized is a keyword and Beta is a target milestone.
>+
>+ ------- Additional Comments From ford@tigris.org 2002-06-29 07:56 PDT -------
>+ uuuh ... brane is right. it works, except that it can't find the binary when started out of a "cmd.exe".
>

I must say I don't understand what you're talking about. Which "it"
can't find which binary? And why can I run the tests from cmd.exe just
fine, but you can't?

>+ i juast had to:
>+ - hardcode the binary paths, including the "debug" build directory
>+ (how to call the original abspath-function to build the path?)
>+ - create a working_copies directory
>

*What* are you trying to do? Have you actually looked ar win-tests.py,
or what? Sorry, but your descriptions of your problems are not very
enlightening.

This is how you run the tests on Windows:

    * Build Subversion (the "__check__" target in subversion.dsw),
      either release or debug.
    * Run win-tests.py from the root of the source tree:
> python win-tests-py release or
> python win-tests.py debug

That's it, no other magic is necessary.

-- 
Brane Čibej   <brane_at_xbc.nu>   http://www.xbc.nu/brane/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sun Jun 30 09:38:32 2002

This is an archived mail posted to the Subversion Dev mailing list.