[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: update problem

From: Ben Collins-Sussman <sussman_at_collab.net>
Date: 2002-06-14 17:13:59 CEST

Paul Marculescu <paul@p16.pub.ro> writes:

> > Okay, here's how the diff-program arg works. It doesn't exist in diffutils
> > 2.7. In diff-utils 2.8 and above diff3 first checks the --diff-program, then
> > a list of compiled in locations (i.e. not $PATH).
>
> I downloaded diff-utils from cygwin, but somehow cygintl-1.dll was
> missing.
> After moving exes from one place to another and changing paths, I
> installed an older version of cygwin (2.125.2.10) (this time without
> changing the list of packages - used the default ones), and the problem
> vanished.
> So it seems that it works even with version 2.7 of diff-utils, as diff3
> -v says "diff3 - GNU diffutils version 2.7-cygwin-990830".

I'm disturbed by all the problems Win32 users have been having trying
to run 'diff3'. From my vantage point, it seems like many people have
problems with diff3, ask for help, try different random re-installs of
cygwin and/or diffutils, and then the problems eventually go away.
And in each case, nobody is really sure what caused or fixed the
problem. This is not Progress. :-(

Maybe we shouldn't be using cygwin binaries of diff3. For example, I
have DOS binaries of diff3 and sitting in a 'utility' folder that has
moved with me from machine to machine for the last 10 years. It has
no dll dependencies, and I'm not sure where they originally come
from...

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Jun 14 17:17:11 2002

This is an archived mail posted to the Subversion Dev mailing list.