[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SVN server working copy compiling problems

From: Philip Martin <philip_at_codematters.co.uk>
Date: 2002-04-30 19:39:21 CEST

Michael Tanaka <michael@gloltd.com> writes:

> ...
> D_SOURCE -D_SVID_SOURCE -g -O2 -pthread -DNEON_ZLIB
> -I./subversion/include -I. -I/usr/local/etc/svn/apr/include
> -I/usr/local/etc/svn/apr-util/include -I/usr/local/etc/svn/neon/src
> -I/usr/local/etc/svn/db/dist -o subversion/libsvn_delta/svndiff.lo -c
> subversion/libsvn_delta/svndiff.c
> In file included from subversion/libsvn_delta/delta.h:24,
> from subversion/libsvn_delta/svndiff.c:24:
> subversion/include/svn_xml.h:30: expat.h: No such file or directory
>
> which required that I dropped into the 'expat' subdirectory (this was in the
> distribution of the 'apr-util' included with subversion-r1682) and compiled

When you used the compiled tarball to check-out the current code there
should not have been an 'expat' directory. Where did it come from?

> and installed this application to create the missing 'expat.h' file, before
> compiling and making the SVN working copy. I mention this because I'm
> concerned it may be the cause or symptomatic of my next problem, although
> this is a pure guess on my part.
>
> re-typing the configure command then gave me:-
>
> ...
> /bin/sh /usr/local/etc/svn/libtool --silent --mode=compile gcc -DLINUX=2
> -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -g -O2
> -pthread -DNEON_ZLIB -I/usr/local/apache2/include -I./subversion/include
> -I.
> -I/usr/local/etc/svn/apr/include -I/usr/local/etc/svn/apr-util/include
> -I/usr/local/etc/svn/neon/src -I/usr/local/etc/svn/db/dist -o
> subversion/mod_dav_svn/mod_dav_svn.lo -c
> subversion/mod_dav_svn/mod_dav_svn.c
> subversion/mod_dav_svn/mod_dav_svn.c: In function `dav_svn_init':
> subversion/mod_dav_svn/mod_dav_svn.c:61: parse error before `APR_STRINGIFY'
> subversion/mod_dav_svn/mod_dav_svn.c: At top level:
> subversion/mod_dav_svn/mod_dav_svn.c:232: warning: excess elements in struct
> initializer
> subversion/mod_dav_svn/mod_dav_svn.c:232: warning: (near initialization for
> `dav_svn_provider')
> make: *** [subversion/mod_dav_svn/mod_dav_svn.lo] Error 1
>
> This is where I'm totally at a loss as to what I should try next. Has anyone
> else had a similar problem and/or can they give me any suggestions to get
> past this point.

APR_STRINGIFY is in apr_general.h. There are probably versions of apr
and apr-util installed with your apache, and the compile line has
-I/usrlocal/apache2/include before -I/usr/local/etc/svn/apr/include.
You probably have an installation of apache in /usr/local/apache2 that
is too old.

One solution is to build and install a newer apache, and configure
subversion to use apache's apr/apr-util, i.e. configure subversion
using
 '--with-apr=/usr/local/apache2 --with-apr-util=/usr/local/apache2'

-- 
Philip
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Apr 30 19:40:26 2002

This is an archived mail posted to the Subversion Dev mailing list.