[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Include order

From: Lele Gaifax <lele_at_seldati.it>
Date: 2002-04-17 19:40:27 CEST

Hi all,

I had a little problem compiling the latest version of svn, due to old
version of svn_*.h around (for testing, I use a common
`/usr/local/SVNdev' prefix for both the latest Apache and
Subversion). The problem raised only in the mod_dav subdir, because
just for those sources a different rule is used (COMPILE_APACHE_MOD),
that is defined as

COMPILE_APACHE_MOD = ... $(APACHE_INCLUDES) $(INCLUDES) -o $@ -c $<

Is there a particular reason for this order? The $(INCLUDES) chunk
starts with '-I./subversion/include', so that it prefers actual
include vs previously installed ones. After the error, it was of
course easy to understand what was going and delete the old include
files, but I think that swapping those variables is safer anyway...

bye, lele.

-- 
nickname: Lele Gaifax	| Quando vivro' di quello che ho pensato ieri
real: Emanuele Gaifas	| comincero' ad aver paura di chi mi copia.
email: lele@seldati.it	|		-- Fortunato Depero, 1929.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Apr 17 19:42:07 2002

This is an archived mail posted to the Subversion Dev mailing list.