[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Installing Subversion

From: <cmpilato_at_collab.net>
Date: 2002-04-12 19:51:21 CEST

Ben Collins-Sussman <sussman@collab.net> writes:

> Peter Davis <pdavis152@attbi.com> writes:
>
> > Being just a little competent in C, I fetched the latest subversion sources
> > and patched in all the changes in the calls to apr_brigade_*(), which take
> > two arguments instead of one like before. But if people don't want to do
> > that by hand, it looks like it is no longer possible to build any current
> > released version of svn with the current apr.
>
> I deny that claim. :-)
>
> I just updated (just a half-hour ago!) my svn working copy (r1679),
> then updated the apr and apr-util trees as well. I then did a 'make
> clean' and completely rebuilt everything without a hitch.
>
> So the question is, what are we doing differently?
>
> Hm. Wait. I'm not building mod_dav_svn. Lemme see if I can
> reproduce.

Well, I *am* building mod_dav_svn. Just built Apache and Subversion
from the HEADS of httpd-2.0, apr, apr-util, and subversion. No
errors.

Perhaps those who are seeing the problems have cruft (previous
versions of apr or apr-util) in their installed header locations?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Apr 12 19:54:42 2002

This is an archived mail posted to the Subversion Dev mailing list.