[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn upgrade -> db unusable

From: Garrett Rooney <rooneg_at_electricjellyfish.net>
Date: 2002-04-09 15:24:17 CEST

On Tue, Apr 09, 2002 at 03:21:49PM +0200, Sander Smeenk wrote:
> Hi,
>
> There's a lot about SVN that I really like, but there's one thing that I
> dislike. Each time I upgrade my SVN, my old repositories become
> unusable:
>
> | Could not open the SVN filesystem at /var/svn/pj/ [500, #21048]
> | (2)No such file or directory: bad database version: 3.2.9 [500, #21048]
>
> I heared someone posted a method to fix the databases to the new
> 'database version', but I couldn't find the post. Will that someone
> please post it again and/or submit it to the FAQ over at
> http://subversion.tigris.org/ ?

there's a script in the tools subdir to do it. enable-dupkeys.sh is
it, if i recall correctly.

-garrett

-- 
garrett rooney                    Remember, any design flaw you're 
rooneg@electricjellyfish.net      sufficiently snide about becomes  
http://electricjellyfish.net/     a feature.       -- Dan Sugalski
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Apr 9 15:25:12 2002

This is an archived mail posted to the Subversion Dev mailing list.