[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn fetch

From: Garrett Rooney <rooneg_at_electricjellyfish.net>
Date: 2001-11-15 14:43:58 CET

On Thu, Nov 15, 2001 at 08:28:38AM -0500, Kevin Pilch-Bisson wrote:

> This does seem reasonable, but I am reminded of something I once read
> about operator overloading in C++. People use it for things that are
> _ALMOST_ the same as what the operator is usually used for. Thus people
> have to check the docs for the operator anyway, when a well named
> function may have been more appropriate.
>
> This seems similar to me: is it going to be easier for people to remember
> the semantics of what will happen with different arguments to svn fetch, or
> to remember what checkout, update, and switch do? I don't know, but
> thought I would see if anyone else does.
>
> Note that this doesn't mean that I am against simplifying, and combining
> the code paths for these functions, just that I am unsure about how to
> present the UI for them.

I agree with everything Kevin just said. Having different commands for
different things, rather than one command with many options, seems
more intuitive to me.

-garrett

-- 
garrett rooney                     Unix was not designed to stop you from 
rooneg@electricjellyfish.net       doing stupid things, because that would  
http://electricjellyfish.net/      stop you from doing clever things.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:48 2006

This is an archived mail posted to the Subversion Dev mailing list.