[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: XEmacs binding

From: Daniel Stenberg <daniel_at_haxx.se>
Date: 2001-10-29 15:41:46 CET

On 29 Oct 2001, Yoshiki Hayashi wrote:

> > If you write an add-on to work license-wise with both XEmacs and Subersion,
> > you must be compatible with both the GPL and Apache(-style) licenses. That's
> > why I suggest the BSD.
>
> You mean if I use BSD license, other person will not be restricted to
> distribute Subversion XEmacs binding (or XEmacs Subversion binding,
> depending on the point of view) binary? Then I'll definitely use it and
> forget about other licenses.

Yes, that is exactly what I say. The so called "modified BSD license" is
deemed compatible with GPL, as can be viewed here:
http://www.gnu.org/licenses/license-list.html#GPLCompatibleLicenses

Source code under the Apache or Subversion licenses don't spread to other
files, so they can be pretty liberally combined with just about everything.

A more FSF'ish person would suggest LGPL as an option too, as that is more in
the GPL spirit while still not polluting its neighbours.

-- 
      Daniel Stenberg - http://daniel.haxx.se - +46-705-44 31 77
   ech`echo xiun|tr nu oc|sed 'sx\([sx]\)\([xoi]\)xo un\2\1 is xg'`ol
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:46 2006

This is an archived mail posted to the Subversion Dev mailing list.