[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: mod_ssl broken

From: Ben Laurie <ben_at_algroup.co.uk>
Date: 2001-09-09 23:06:45 CEST

Doug MacEachern wrote:
>
> On Sun, 9 Sep 2001, Sander Striker wrote:
>
> mod_ssl is working fine here, passes all httpd-test tests (t/TEST -ssl)
> that includes perdir merging.
> are you up to date with httpd-2.0 from cvs?

Yes.

>
> > mod_ssl segfaults in ssl_config_perdir_merge:
> > Program received signal SIGSEGV, Segmentation fault.
> > [Switching to Thread 1024 (LWP 9130)]
> > 0x806dd1d in ssl_config_perdir_merge (p=0x814e22c, basev=0x0,
> > addv=0x8192e4c) at ssl_engine_config.c:269
> > 269 cfgMergeArray(aRequirement);
> > (gdb) bt
> > #0 0x806dd1d in ssl_config_perdir_merge (p=0x814e22c, basev=0x0,
> > addv=0x8192e4c) at ssl_engine_config.c:269
>
> i don't think basev should ever be NULL here. can somebody confirm?
>
> > #1 0x80a2c15 in ap_merge_per_dir_configs (p=0x814e22c, base=0x8192f34,
> > new_conf=0x8192c54) at config.c:262
> > #2 0x80b7376 in ap_location_walk (r=0x814e25c) at request.c:1236
>
> this is in the area of new directory/location walk optmizations, i have a
> feeling the bug is there, not mod_ssl. wrowe could probably provide some
> insight here.

I am absolutely sure it is there (see my posts).

Cheers,

Ben.

--
http://www.apache-ssl.org/ben.html
"There is no limit to what a man can do or how far he can go if he
doesn't mind who gets the credit." - Robert Woodruff
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:41 2006

This is an archived mail posted to the Subversion Dev mailing list.