[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: CVS update: MODIFIED: libsvn_wc ...

From: Ben Collins-Sussman <sussman_at_collab.net>
Date: 2001-06-09 13:44:17 CEST

Greg Stein <gstein@lyra.org> writes:
> The stream concept for "feedback" is inappropriate for a library. It is just
> another name for the library printing to stdout or stderr.

For the past year, there have been about a zillion times when we've
wanted some library routine to return a *warning* to the user without
interrupting program flow. How can you say that library isn't allowed
to do this? Certainly libraries *need* to provide feedback... maybe
just not with a generic stream. :)

> Please, please, please... do not depend on this stream thing. It creates a
> serious inflexibility for the system(*). Provide *structured* feedback calls
> for this kind of informatin.

Yes, after implementing the stream, Jim Blandy pointed out that a
random stream of feedback bytes is too unstructured.

We all agreed that the *correct* solution is to hang a vtable off of
the top-level pool instead of a stream. Whenever a library wants to
send a new kind of feedback to the client app, we can add new vtable

For now, the vtable should probably contain only one func:

   void warn_about_unversioned_item (const char *path);

The update-reporter can call this, and the client can interpret it
however it wants, such as printing a question mark.

This is what you had in mind, too, right Greg?

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:31 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.