On Fri, Dec 22, 2000 at 02:02:33PM -0600, Karl Fogel wrote:
> Bill Tutt <email@example.com> writes:
> > I left the compose_editors.c function named delete, because the libc
> > remove() prototype was giving MSVC fits.
> Hmmm. That's problematic. It's good for them to match, for clarity's
> sake. (It's not only an issue in libsvn_delta/compose_editors.c, but
> also in libsvn_wc/get_editor.c, libsvn_delta/xml_output.c,
> client/trace.c, libsvn_ra_dav/commit.c, and libsvn_ra_dav/fetch.c.)
> So, `delete' is taken, and `remove' is taken? Sheesh.
> For now, I'll change it to `delete_anything', which is annoyingly
> verbose. But it avoids the namespace problem, allowing us to use the
> same name for prototype and implementation, and gives us an obviously
> unique string to do an auto replace on if/when we think of a better
> name later.
I'd suggest "delete_item".
Greg Stein, http://www.lyra.org/
Received on Sat Oct 21 14:36:18 2006