[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: "Invalid authz configuration" verbose?

From: Alvaro Gonzalez <agonzale_at_cern.ch>
Date: Fri, 4 Nov 2011 14:40:52 +0100

I will take a look, thank you

On 04/11/11 12:45, Daniel Shahaf wrote:
>
> On Friday, November 04, 2011 12:15 PM, "Alvaro Gonzalez"<agonzale_at_cern.ch> wrote:
>> Hello,
>>
>> I have encountered from time to time the problem that someone (or an
>> script) modified an authz file in such a way that it blocked the access
>> completely to the repository:
>>
>> "Invalid authz configuration"
> ...
>> my question is, is there any way to have a better error report of the
>> problem? I often have problems in some authz files which are very long,
>> and it is not trivial to find the problematic group.
>>
>> Do you have any suggestion?
>>
> Use the svnauthz-validate tool (probably packaged in the 'svn-tools' package of your OS, or 'make svnauthz-validate install-tools' if you build from source).
>
> Send patches against libsvn_repos/authz.c that add the section name, key name, line number, etc to the error message.
>
> http://subversion.apache.org/patches
>
> Thanks!
>
>> Cheers
>>
>> --
>> Alvaro Gonzalez Alvarez IT/PES-IS
>> CERN - European Organization for Nuclear Research
>> Phone: 0041 22 76 77 118
>> 1211 Geneva - Switzerland, CERN Office: 31/1-026
>>
>>

-- 
      Alvaro Gonzalez Alvarez IT/PES-IS
      CERN - European Organization for Nuclear Research
      Phone: 0041 22 76 77 118
      1211 Geneva - Switzerland,  CERN  Office: 31/1-026
Received on 2011-11-04 14:41:29 CET

This is an archived mail posted to the Subversion Users mailing list.