[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: updates on subdirectories : revision not being pulled

From: Igor DEFAYE <i.defaye_at_sitealpha.ca>
Date: Thu, 11 Aug 2011 17:27:18 -0400

 

 

De : Igor DEFAYE
Envoyé : 11 août 2011 17:26
À : 'Mark Phippard '
Cc : 'users_at_subversion.apache.org'
Objet : RE: updates on subdirectories : revision not being pulled

 

Hello,

 

Thanks for your prompt reply. Unfortunately your email landed in the spam folder of our mail server, so I only got it today when the admin looked in the spam folder.

 

What you say would explain what we see on the change log. Even though I find really it confusing that in this case some revisions are deleted from the changelog on subdirectories and not on higher directories. It's not consistent.

 

Anyhow, may be this was not a good example after all, but that was the only visible case so far that showed something to explain the problem we face.

 

We have other cases of update not happening and when committing the files are replaced with older versions. We will look deeper into the problem to try to find some explanations of what happens. We had a lot of bug regressions lately, it was just code that had disappeared, as if a revision was removed. Those that committed the files that 'reverted' the code had no conflicts or warning whatsoever from svn.

 

If you know anything that could cause this kind of problem, bad server configuration, svn client problem, etc... I would be happy to hear about it so we can resolve this issue.

 

Thanks in advance,

 

Igor Defaye

Development Team Manager.

Site Alpha Group Planon

 

 

De : Mark Phippard [mailto:markphip_at_gmail.com]
Envoyé : 9 août 2011 14:32
À : Igor DEFAYE
Cc : users_at_subversion.apache.org
Objet : Re: updates on subdirectories : revision not being pulled

 

On Tue, Aug 9, 2011 at 1:57 PM, Igor DEFAYE <i.defaye_at_sitealpha.ca> wrote:

 

        We have a major problem on our Apache Subversion. When updating some revisions are not pulled down to the pc, regardless of which pc we use.

        This seems to happen only when updating from a sub-directory and not updating from root directory, but it might also happen from root dir, I've just haven't seen it happen yet.

        I don't know if this is an already known issue, or if I need to submit a new one. So I hope someone can help me look rapidly over this.

         

        Our server is up to date : 1.6.17 build 2190.74 . We administer the server via Collabnet Subversion Edge. We mostly use tortoise svn clients, they were updated but the problem is server side.

         

        We have noticed the revisions that are not pulled down to the pcs also do not appear in the change log on the subdirectory, but does on higher directories.

         

        May be an example will make it clearer :

        On root directory we see the change log for revision 20445, it concerns only one file : /SuiteFM_dot_Net/Bin/www/ope_RAPPORT/js/container.js

        Both Collabnet or tortoise show the same, so far so good.

 

Please do not mail dev@. This is not a discussion about the development of Subversion.

 

Based on your screenshots, I would suggest you look at revision 20453. If someone replaced the folder in that commit with an earlier version from its history than everything in your screenshots makes perfect sense. Basically @ revision 20453, the folder was replaced, creating a new line of history that does not include those other revisions.

 

 

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
Received on 2011-08-11 23:26:57 CEST

This is an archived mail posted to the Subversion Users mailing list.