[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Can do all svn commands except commit, which won't authorize

From: Bryan Hanson <hanson_at_depauw.edu>
Date: Mon, 21 Sep 2009 11:07:10 -0400

Forgot to add that I also have svnX installed. Trying to commit with either
svnX or SCPlugin leads to the same error.

Thanks again. Bryan

On 9/21/09 10:57 AM, "Bryan Hanson" <hanson_at_depauw.edu> wrote:

> Hello. I¹m totally new to this, so I¹m hoping I¹ve missed the obvious.
>
> I have a repository set up on R-Forge. I am running Mac OSX 10.5.8,
> subversion 1.6.5 and have SCPlugin installed. I have an ssh key set up and
> working (originally with SSHkeychain which seemed to behave a bit flaky, now
> with SSH Agent which seems fine). I¹ve been through the subversion mail
> archives, and checked with the R-Forge admin¹s who aren¹t very familiar with
> Mac.
>
> Problem: I can do any svn command except commit, which gives me an error. I
> do have something to commit:
>
> bryanhanson% svn status
> M R/HCA.R
>
> But it won¹t commit:
>
> bryanhanson% svn commit -m "testing commit"
> svn: Commit failed (details follow):
> svn: Authorization failed
>
> I can do other things, like make directories (and really most everything else
> I¹ve tried seems to work):
>
> bryanhanson% svn mkdir -m "temp test dir"
> svn+ssh://bryanhanson@svn.r-forge.r-project.org/svnroot/chemospec/pkg/chemospe
> c/test
>
> Committed revision 42.
>
> Everything I ask it to do at the repository is done, as judged by browsing the
> repository. If I try %svn commit ­m ³msg² --username etc the behavior is the
> same. I can and have checked out files. %svn status ­v returns all the right
> info.
>
> I have checked the keychain and it does not have anything related to svn in
> it. I have inspected ~/.subversion/auth and all the subdirectories are empty
> (which strikes me as strange). I did have some trouble with the ssh system
> initially, but it seems to work now (and ~/.ssh has the correct files, each
> with what seems to be correct content). I feel like the problem is an
> orphaned incorrect password, or missing password, but I¹m not certain and I
> don¹t know where it might be located if that¹s even what¹s going on.
>
> I¹m quite stuck here, so I¹m hoping someone can help. TIA Bryan
> *************
> Bryan Hanson
> Professor of Chemistry & Biochemistry
> DePauw University, Greencastle IN USA
>

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2397498

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-09-21 17:08:05 CEST

This is an archived mail posted to the Subversion Users mailing list.