[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE:[SOLVED] Reintegrate issue with v1.6.5

From: Erik Hemdal <erik_at_comprehensivepower.com>
Date: Fri, 4 Sep 2009 14:44:06 -0400

> -----Original Message-----
> From: Bob Archer [mailto:bob.archer_at_amsi.com]
> Sent: Friday, September 04, 2009 12:24 PM
> To: Erik Hemdal; users_at_subversion.tigris.org
> Subject: RE: Reintegrate issue with v1.6.5
>
>
> > I'm experiencing the following reintegrate error when
> trying to move a
> > feature branch back to trunk. (this is the output from TortoiseSVN):
> >
> > Error: Reintegrate can only be used if revisions 320 through 364 were
previously
> > Error: merged from svn://server/project/trunk to the reintegrate
> > source, but
> >

. . . .

> Another thing you
> could do is remove the merge info from DEV_BRANCH/folder1 and
> DEV_BRANCH/folder2 making sure that all the merge info is on
> the DEV_BRANCH folder.

This did the trick. It looks like mergeinfo got into the subtrees when
someone merged a only a portion of the project. I verified with TortoiseSVN
> Properties that the mergeinfo on my DEV_BRANCH folder had the trunk
revisions I needed and then removed the mergeinfo on the subtrees. The
resulting merge looks correct and passes my tests. Thanks for the help,
Bob. You gave me the trailhead I needed.

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2391079

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-09-04 20:45:03 CEST

This is an archived mail posted to the Subversion Users mailing list.