[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Upgrading from 1.4 to 1.6.3

From: Stefan Sperling <stsp_at_elego.de>
Date: Fri, 10 Jul 2009 18:53:10 +0100

On Fri, Jul 10, 2009 at 01:37:28PM -0400, Vitaliy Sholokhov wrote:
> This is all I get in the error log:
>
> [Fri Jul 10 13:10:03 2009] [notice] Apache configured -- resuming normal
> operations
> [Fri Jul 10 13:10:09 2009] [error] [client 10.2.57.17] (20014)Error
> string not specified yet: SQLite compiled for 3.6.14.2, but running with
> 3.3.7

That's bad. Somewhere there's a mismatch between the SQlite version
which was compiled with vs. the one being picked up at runtime.

If this mismatch is really happening in Subversion and not somewhere else:
To avoid this, make sure that LD_LIBRARY_PATH has the correct directory
for the newer SQlite listed at the front (on Linux), or recompile Subversion
the sqlite amalgamation file to avoid linking against SQlite as a shared
library entirely. Then the SQlite version at run time will definitely
match the one used at compile time.

Stefan
Received on 2009-07-10 19:54:18 CEST

This is an archived mail posted to the Subversion Users mailing list.