[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: XCode Subversion 1.5

From: Kyle McKay <mackyle_at_gmail.com>
Date: Thu, 2 Apr 2009 12:08:51 -0700

On Apr 2, 2009, at 02:33:08 PDT, Andrew Zahra <work_at_zguy.com> wrote:
> Can someone point me at current information on setting up xcode with
> subversion 1.5? I have Xcode 3.1.3 and I get the "your client is too
> old" message when I try and work with the working copy I checked out
> from command line. I had assumed Xcode didn't support 1.5 but it
> seems from various messages and the release notes that it is
> supposed to.
> thanks,
> Andrew

The instructions here will work just fine:


I recommend you stick with 1.5.6 for now and avoid 1.6.x. You can get
a 1.5.6 installer that will work with the above instructions from:


As for why 1.6.0 and later are bad, read this:


and then see this:


for more information about why 1.6.0 was broken to create zombies
including much more detail and a patch to fix the problem.


P.S. If you want to see if any patch/fix has actually been applied to
Subversion to eliminate the zombie problem, you can check the log here:


(Currently the trunk of Subversion is still broken in that it
continues to create zombies.)


To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-04-02 21:12:31 CEST

This is an archived mail posted to the Subversion Users mailing list.