[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Dropping support for Windows '9X and NT 4.0 in Subversion 1.6?

From: Pat Farrell <pfarrell_at_pfarrell.com>
Date: Thu, 18 Sep 2008 00:36:52 -0400

Bert Huijben (TCG) wrote:
> Just a quick question to you all. Do you use a current subversion release
> (1.4 or 1.5) on Windows '9X or NT 4.0?
> Microsoft dropped the support for these windows versions a few years ago

I believe, IMHO, that there is no point in providing "support" longer
than say 12 months after the vendor kills support.

Win9x was used well into the XP era, but I'm not sure that the SVN
target audience (developers, etc) would keep using really old versions.

I'm afraid its been too long, is NT4.0 the version before Windows 2000?
I think that even W2K fails the "12 months after the vendor stops
support policy.

What's not as clear to me is how this fits into various Linux distros.
Ubuntu, for example, has a fairly short "support" policy for non-LTS
versions.

But the principal here has to be, at some date, supporting really old
stuff is more work for the subversion team (and any other team) than its
worth.

IMHO, YMMV, etc
Pat

-- 
Pat Farrell
http://www.pfarrell.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: users-help_at_subversion.tigris.org
Received on 2008-09-18 06:36:45 CEST

This is an archived mail posted to the Subversion Users mailing list.