[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Failed to add directory...

From: Carlos Peix <peix-listas_at_praxia.com.ar>
Date: 2007-10-31 13:37:35 CET

Anyone willing to take this one?

Thanks

Carlos Peix

> -----Original Message-----
> From: Carlos Peix [mailto:peix-listas@praxia.com.ar]
> Sent: Martes, 30 de Octubre de 2007 12:14 p.m.
> To: users@subversion.tigris.org
> Subject: RE: Failed to add directory...
>
> Thanks for your time Ryan,
>
> I tried to do the reproduction recipe you requested and I
> can't repeat the error, so I'll try to describe the
> environments where I have the problem.
>
> Those are the differences between the enviroments that work
> OK and those that fail as detailed in my first post:
>
> Environmet that works:
> - Suversion 1.4.5 in english
> - With the working folder fully update from repo:
> <Screen capture>
> D:\Temp\WebFeel>svn update
> At revision 56.
>
> D:\Temp\WebFeel>svn st
> ? Ankh.Load
> ? back
> ? WebFeel.suo
> </Screen capture>
> Which is OK because the "back" folder and the "Ankh.Load" and
> "WebFeel.suo"
> files are not under Subversion control.
>
>
> Environmet that fails:
> - Suversion 1.4.5 in spanish
> - With the working folder fully update from repo:
> <Screen capture>
> C:\Proyectos.NET\WebFeel>svn update
> En la revisión 56.
>
> C:\Proyectos.NET\WebFeel>svn st
> ? Ankh.Load
> ? back
> ? tools
> ? doc
> ? lib
> ? src
> ? WebFeel.suo
> </Screen capture>
> Which is NOT OK because the "back" folder and the "Ankh.Load"
> and "WebFeel.suo"
> files are not under Subversion control but the other folders
> are under Subversion control as can be seen in the output from svn st.
> <Screen capture>
> C:\Proyectos.NET\WebFeel>svn st tools
>
> C:\Proyectos.NET\WebFeel>svn st doc
>
> C:\Proyectos.NET\WebFeel>svn st lib
>
> C:\Proyectos.NET\WebFeel>svn st src
> ? src\Website
>
> C:\Proyectos.NET\WebFeel>svn update
> En la revisión 56.
> </Screen capture>
>
> The problem reported appears each time somebody commits to
> the repo (myself or another developer) and I can resolve the
> problem moving to the folder that contain changes and doing
> some combination of "svn update" and "svn update
> non-recursive" (issued in the command line or TortoiseSVN).
>
> What are I doing wrong?
>
> Thanks
>
> Carlos Peix
>
> > -----Original Message-----
> > From: Carlos Peix [mailto:peix-listas@praxia.com.ar]
> > Sent: Martes, 30 de Octubre de 2007 11:26 a.m.
> > To: 'Ryan Schmidt'
> > Subject: RE: Failed to add directory...
> >
> > Thanks for your time Ryan,
> >
> > I tried to do the reproduction recipe you requested and I
> can't repeat
> > the error, so I'll try to describe the environments where I
> have the
> > problem.
> >
> > Those are the differences between the enviroments that work OK and
> > those that fail as detailed in my first post:
> >
> > Environmet that works:
> > - Suversion 1.4.5 in english
> > - With the working folder fully update from repo:
> > <Screen capture>
> > D:\Temp\WebFeel>svn update
> > At revision 56.
> >
> > D:\Temp\WebFeel>svn st
> > ? Ankh.Load
> > ? back
> > ? WebFeel.suo
> > </Screen capture>
> > Which is OK because the "back" folder and the "Ankh.Load" and
> > "WebFeel.suo" files are not under Subversion control.
> >
> >
> > Environmet that fails:
> > - Suversion 1.4.5 in spanish
> > - With the working folder fully update from repo:
> > <Screen capture>
> > C:\Proyectos.NET\WebFeel>svn update
> > En la revisión 56.
> >
> > C:\Proyectos.NET\WebFeel>svn st
> > ? Ankh.Load
> > ? back
> > ? tools
> > ? doc
> > ? lib
> > ? src
> > ? WebFeel.suo
> > </Screen capture>
> > Which is NOT OK because the "back" folder and the "Ankh.Load"
> > and "WebFeel.suo" files are not under Subversion control
> but the other
> > folders are under Subversion control as can be seen in the
> output from
> > svn st.
> > <Screen capture>
> > C:\Proyectos.NET\WebFeel>svn st tools
> >
> > C:\Proyectos.NET\WebFeel>svn st doc
> >
> > C:\Proyectos.NET\WebFeel>svn st lib
> >
> > C:\Proyectos.NET\WebFeel>svn st src
> > ? src\Website
> >
> > C:\Proyectos.NET\WebFeel>svn update
> > En la revisión 56.
> > </Screen capture>
> >
> > The problem reported appears each time somebody commits to the repo
> > (myself or another developer) and I can resolve the problem
> moving to
> > the folder that contain changes and doing some combination of "svn
> > update" and "svn update non-recursive" (issued in the
> command line or
> > TortoiseSVN).
> >
> > What are I doing wrong?
> >
> > Thanks
> >
> > Carlos Peix
> >
> > > -----Original Message-----
> > > From: Ryan Schmidt [mailto:subversion-2007b@ryandesign.com]
> > > Sent: Lunes, 29 de Octubre de 2007 05:19 p.m.
> > > To: peix-listas@praxia.com.ar
> > > Cc: users@subversion.tigris.org
> > > Subject: Re: Failed to add directory...
> > >
> > > On Oct 29, 2007, at 14:33, Carlos Peix wrote:
> > >
> > > > Sorry for the svn messages in spanish, I think that they
> > are pretty
> > > > clear anyway.
> > > >
> > > > In the following sequence I'm using svn 1.4.5 (r25188)
> > > against a svn
> > > > server (same version) and I'm the only developer against the
> > > > repository.
> > > >
> > > > TortoiseSVN is installed but not used to reproduce the problem.
> > > >
> > > > I can reproduce the problem with the following:
> > > >
> > > > C:\Proyectos.NET\HLServer>svn update En la revisión 51.
> > > >
> > > > C:\Proyectos.NET\HLServer>cd doc
> > > >
> > > > C:\Proyectos.NET\HLServer\doc>copy con help.txt Hello world ^Z
> > > > 1 archivos copiados.
> > > >
> > > > C:\Proyectos.NET\HLServer\doc>svn add help.txt
> > > > A help.txt
> > > >
> > > > C:\Proyectos.NET\HLServer\doc>svn update En la revisión 51.
> > > >
> > > > C:\Proyectos.NET\HLServer\doc>svn commit -m "Test"
> > > > Añadiendo help.txt
> > > > Transmitiendo contenido de archivos .
> > > > Commit de la revisión 52.
> > > >
> > > > C:\Proyectos.NET\HLServer\doc>svn update En la revisión 52.
> > > >
> > > > C:\Proyectos.NET\HLServer\doc>cd..
> > > >
> > > > C:\Proyectos.NET\HLServer>svn update
> > > > svn: No se pudo lockear 'doc'
> > > >
> > > > C:\Proyectos.NET\HLServer>svn update
> > > > svn: Falló el añadido del directorio 'tools': ya existe un
> > > objeto del
> > > > mismo nombre
> > > >
> > > > No other commands run against the repo.
> > >
> > > Can you provide a complete reproduction recipe, beginning with
> > > "svnadmin create"?
> > >
> > >
> > >
> >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > > For additional commands, e-mail: users-help@subversion.tigris.org
> > >
> > > __________ Información de NOD32, revisión 2623 (20071029)
> __________
> > >
> > > Este mensaje ha sido analizado con NOD32 antivirus system
> > > http://www.nod32.com
> > >
> > >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>
> __________ Información de NOD32, revisión 2627 (20071030) __________
>
> Este mensaje ha sido analizado con NOD32 antivirus system
> http://www.nod32.com
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Oct 31 13:38:02 2007

This is an archived mail posted to the Subversion Users mailing list.