[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

More fun w/ working copy on SMB share

From: Markus S <youcontrol_at_hispeed.ch>
Date: 2007-06-21 16:03:31 CEST

Hi,

recently, I reported here that adding empty files to repositories (even
if they are deleted again) in the inability to interact with a working
copy on a SMB share accessed from Mac OS X 10.4.x (see my post from 8
June: Commit failed: 'Can't copy ... Input/output error').

I now had trouble with a word file. It worked fine with my local
working copy until I checked it out (via update) to a working copy on a
SMB share. There, the update would fail (with "Can't copy ...").
Subsequent attempts to do anything with the working copy would fail
with "The working copy is locked". I had to delete the working copy and
check it out again to get it working.

Deleting the word file from the repository and adding the same file
under a different name produced the same results. Resaving the file in
word under a different name and adding it again worked however.

I could imaging that resource forks might play a role but why resaving
it under a different name fixes it, I have no idea.

Markus

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Jun 21 17:01:33 2007

This is an archived mail posted to the Subversion Users mailing list.